24th November 2019

[RESOLVED]MI3-SR1:: Service Interruption

mi3-sr1 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:28 PM EST: Our System Operations team has resolved this matter and MI3-SR1 services are back online.