21st November 2019

[RESOLVED]mi3-wts4 :: Emergency Maintenance

We are currently aware of Emergency Maintenance being performed on mi3-wts4.a2hosting.com. Users on the server will be unable to reach their services as a result. Expected downtime time is two to four hours. 

UPDATE 12:55 PM EST: Our System Operations has completed maintenance and all services are back online.