18th November 2019

[RESOLVED]Network Interruption

Some servers in our Arizona network are currently experiencing a service interruption. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:01 AM EST: Our System Operations team has resolved this matter and the network is stable. We will continue to monitor the network for stability and performance.