12th November 2019

[RESOLVED]mi3-ss30 :: Service Interruption

mi3-ss30.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:45 PM EST: Our System Operations team has resolved this matter and all services are back online.