12th November 2019

[RESOLVED]Michigan DC :: Partial Service Interruption

Our Michigan facility is currently experiencing a service interruption. Some users hosted in this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 11:07 AM EST: Our System Operations team has resolved this matter and all servers are back online at this time. We will continue to monitor the situation closely.