10th November 2019

[RESOLVED] MI3-WSS2 :: Service Interruption

MI3-WSS2 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

[RESOLVED] UPDATE As of 8:27 PM EST :: Our system admin team was able to get all services back online and stable. They will be further investigating into what caused the issue.