9th November 2019

[RESOLVED] MI3-SR7 :: Service Interruption

mi3-sr7 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:17 AM EST:  Issues on mi3-sr7 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.