3rd November 2019

[RESOLVED] NL1-SR3 :: Service Interruption

NL1-SR3  is currently experiencing an interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 3:02 PM EDT: Our System Operations team has resolved this matter and all services are back online.