3rd November 2019

[RESOLVED] mi3-wss2 :: Service Interruption

mi3-wss2.a2hosting.com is currently experiencing an interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:55 AM EDT: Our System Operations team has resolved the issues and all services are back online.