28th October 2019

[RESOLVED]ssr13 :: Service Interruption

ssr13.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 2:02 PM EDT: Our System Operations team has resolved this matter and all services are back online.