23rd January 2018

SSR24 :: Service Interruption

SSR24 is currently experiencing a service interruption. Users will experience service degradation as a result.

UPDATE 2:20 AM EST: The server is still experiencing network issues, causing service interruptions.

UPDATE 7:00 AM EST: The server is back online. We are still monitoring it but we do not expect any more issues.