25th October 2019

Amsterdam DC :: Intermittent Connectivity

Our Amsterdam Data Center is currently experiencing intermittent connectivity & speed issues. During this time, you may encounter intermittent degraded performance or connectivity. Our System Operations team is currently working on the issue. We will update you with additional information as it becomes available.

UPDATE 12:30 PM EDT: Our System Engineers are currently working on restoring stability. We will continue to provide updates as they become available.

UPDATE 1:30 PM EDT: Our System Engineers are still working on stabilizing connectivity and speed. We will continue to provide updates as they become available.

UPDATE 3:33 PM EDT: Our System Engineers are currently working on restoring stability. We will continue to provide updates as they become available.