22nd October 2019

[RESOLVED]my.a2hosting.com :: Scheduled Maintenance

Start Date: Tuesday, October 22, 2019

End Date: Tuesday, October 22, 2019

Time: 5:00 AM - 7:00 AM EST (9:00 AM - 11:00 AM UTC)

Description: Our Web Development team will be performing routine scheduled maintenance on our customer portal. Customers will be unable to place orders, pay invoices and our customer portal at https://my.a2hosting.com will be unavailable.

UPDATE 9:21 AM EDT: We have completed scheduled maintenance and our customer portal is back online at this time.