6th October 2019

RESOLVED ssr21 :: Service Interruption Email Services

ssr21 is currently experiencing a service interruption with email services Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 9:40 PM EDT: Our System Operations team has resolved this matter and all services are back online.