24th September 2019

[RESOLVED]my.a2hosting.com :: Service Interruption

my.a2hosting.com is currently experiencing an intermittent service interruption. Users attempting to login to https://my.a2hosting.com may experience a 503 error as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:31 PM EDT: Our System Operations team has corrected this issue and users can now login to the customer portal without issues.