24th September 2019

[RESOLVED]Let's Encrypt

Currently, cPanel appears to be experiencing an issue with the Let's Encrypt service, preventing SSLs from being renewed, validated, and installed for domains within cPanel. Updates will be provided as we receive them from cPanel.

UPDATE 12:50 PM EDT: Our System Operations team continues to work with cPanel on correcting this matter. We will continue to provide updates as they are made available.

UPDATE 3:40 PM EDT: Our System Operations team has resolved this matter and all Lets Encrypt SSL certificates will issue as normal now.

September 25th

Update 12:30 AM EDT: We have again noticed issues on few servers and our System Operations team is working on it. More information will be provided as soon as we'll have it available.

UPDATE 12:25 PM EDT: Our System Operations team has resolved this matter and all Let's Encrypt SSL certificates will issue as normal now.