17th September 2019

[RESOLVED] mi3-wss12 :: Maintenance

mi3-wss12 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is working on the server. We will provide updates as more details are made available.

UPDATE 09:30PM EDT:  Issues on mi3-wss12 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.