7th September 2019

[RESOLVED] MI3-WSR1 :: Reboot required.

mi3-wsr1.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 2:40 PM EDT: Our System Operations team has confirmed all services are back online.