22nd December 2017

SRC6 :: Server Offline

SRC6 is currently experiencing an interruption.

Update 20:30 EST SRC6 is currently offline. Our Engineering team is working to get the service back online as soon as possible.

Update 21:30 EST SRC6 is back online. Please do not hesitate to reach out to our Guru crew if you have any further issues.