3rd September 2019

[RESOLVED]mi3-ls7 :: Reboot Required

mi3-ls7.a2hosting.comĀ is currently being rebooted to correct an issue. Users hosted on this server will experience a short downtime (approximately 5 minutes or less.) We will provide updates as more details are made available.

UPDATE 11:56 AM EDT: The server has been rebooted and all services are back online.