29th August 2019

sgss5 :: Maintenance [Completed]

Our System Operations team will be performing a maintenance on the server shortly. Users will experience a brief service interruption (approximately 1-2 hours at maximum) while the maintenance is performed. This is to ensure long term performance and stability of the server. We appreciate your patience and understanding in this regard.

UPDATE 5:15PM EDT: Our System Operations team has started maintenance on the server. We will provide updates as more information is available in this regard.

UPDATE 6:10PM EDT: Maintenance has been completed for the server. Please reach out to our Support should you continue to encounter any issues.