28th July 2019

[RESOLVED] Michigan DC :: Partial Interruption

Our Michigan facility is currently experiencing a service interruption on a small number of servers. Some users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 12:40 PM  :: Our Engineering and Operations teams have corrected the connectivity issue affecting Some of the Michigan Servers. We will continue to monitor our Michigan data center for any issues and provide updates should any arise.