28th July 2019

Singapore Data Center :: Service Interruption

Our Singapore facility is currently experiencing a service interruption. Users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 5:20AM :: Our Engineering and Operations teams continue to work to resolve the connectivity issues affecting Singapore. Updates will be provided as soon as they are available.

UPDATE 6:00AM :: Our Engineering and Operations teams have corrected the connectivity issue affecting Singapore. We will continue to monitor our Singaporean data center for any issues and provide updates should any arise.