25th July 2019

[RESOLVED]ssr12 :: Service Interruption

ssr12 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:35PM EDT:  Issues on ssr12 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.