22nd July 2019

[RESOLVED]mi3-wss3 :: Service Interruption

mi3-wss3.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team are investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 12:18 PM EDT: Our System Operations team has corrected this issue and all services are back online.