27th November 2017

Outbound Email Issues

Our Engineers are investigating reports of intermittent issues with outbound email which is affecting customers on Shared & Reseller Web Hosting services.

Update 17:00 EST 11/27/17: We are glad to report that all mail issues have been resolved. Mail delivery has returned to normal, and is still be watched carefully.

Update 2:45 AA EST 11/28/2017: We have not noticed any additional issues related to the email service and we are now closing this status notice. Please let us know if you run into any more issues with the service.