17th July 2019

[RESOLVED]mi3-wts10 :: Reboot Required

mi3-wts10.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience brief service degradation as a result. We will provide updates as more details are made available.

UPDATE 11:35 AM EDT: Our System Operations team has confirmed the server is back online at this time.