2nd July 2019

[RESOLVED] A2Hosting.com :: Service Interruption

A2Hosting.com is currently experiencing a service interruption. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:16 AM EDT: Our System Operations team has corrected this issue and A2Hosting.com is back online at this time.