16th June 2019

Michigan Data Center Service Interruption

Our Michigan facility is currently experiencing a service interruption. Users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

Update 16 June 2019 1:25AM :: Our Engineering and Operations teams are working to bring all services back online at this time. We'll provide further updates as they become available.

Update 16 June 2019 2:20 AM :: Our Engineering and Operations teams have restored most services at this time. We'll continue to work to ensure all services are brought back online shortly.

Update 16 June 2019 3:00 AM :: At this time, all services should once again be available. We'll continue to monitor the server for any ongoing issues.