11th June 2019

[Resolved] mi3-wts4 :: Reboot Required

mi3-wts4.a2hosting.com is currently being rebooted to correct an issue. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

Update: 8:25 AM EDT :: The issue has been resolved and the service is back online.