11th June 2019

[RESOLVED] a2s52 :: Maintenance Required

Our System Operations team will be performing unscheduled maintenance on a2s52.a2hosting.com. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 4:30PM EDT:  Issues on a2s52 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.