9th June 2019

[RESOLVED] MI3-WTS10 :: Service Interruption

MI3-WTS10  is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 1PM EDT :: The issue has been resolved and the service is back online.