19th November 2017

Partial Network Interruption

Some servers on our network are currently experiencing an interruption. Our Engineers have mitigated a DDOS attack against a server within our infrastructure and services have returned to normal. If you experience any connectivity related issues, please do not hesitate to contact our support and and we will be glad to look into it further.

Update: As of 10:00 EST we are still experiencing network latency. Our engineering team is working to resolve the issue.

Update: As of 12:00 Am EST, the network issue has been resolved and we do not see any more connectivity problems.