25th May 2019

[RESOLVED] nl1-wts1 :: Plesk Service Interruption.

nl1-wts1.a2hosting.com is currently experiencing a service interruption with the Plesk service. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE  This was resolved some time ago and the Plesk service is indeed working as it should, please let us know if you're still experiencing issues.