20th May 2019

[RESOLVED] MI3-WTS9 :: Service Interruption.

mi3-wts9.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 10:24 AM EST Our system engineers have now rectified the issue and all sites are now operating as they should do, please let us know if you have any further issues.