16th May 2019

[RESOLVED] Singapore Data Center :: Service Interruption

 Our Singapore facility is currently experiencing a service interruption. Users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 9:00AM Eastern :: The issue in the Data Center has been addressed and servers should now be loading normally. Our System Operations team will continue to monitor the situation.