14th May 2019

[RESOLVED] MI3-SS13 :: Service Interruption

mi3-ss13.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 3:42PM Eastern :: The issue with this server has been corrected and the service is back online.