14th May 2019

[RESOLVED] MI3-WSQ1 :: Service Interruption

MI3-WSQ1 - is currently experiencing a service interruption.  We are performing RAID Maintenance to that server. We will provide updates as more details shortly as this is completed.

UPDATE As of 2:15PM EST ::  We're please to announce this has now been completed.