19th April 2019

[RESOLVED]Signapore DC : Connectivity Interruption

We are currently experiencing a service interruption in our Singapore data center. Users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 9:45 AM EDT: Our System Operations team has restored connectivity. If you are still experiencing issues please contact our support team directly through our customer portal.