2nd April 2019

[RESOLVED]Singapore facility service interruption

We are currently experiencing a service interruption in our Singapore facility. Users hosted on this location will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 5:15 AM EDT: The issue has been resolved and all affected services are back up now.