25th March 2019

mi3-sr7.supercp.com :: Service Interruption

mi3-sr7.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:15 PM EDT:  Our Engineers are still working on this issue.  We will update when more information is available.

UPDATE 11:55 PM EDT: All services are responding fine as normal. Please reach out to our live support should you continue to encounter any issues.