6th March 2019

[RESOLVED]mi3-ss36 :: Service Interruption

mi3-ss36.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

Update 11:11 AM EST: Our System Operations team has corrected this matter and all services are online at this time.